Knowledgebase: Errors & Common Problems
Smarty Support is Ending
Posted by Mark [Elevated X Support], Last modified by John [Elevated X Support] on 03 March 2022 04:27 PM


Smarty Support is Ending

For security, PHP 8 will be required by our software on January 31st, 2024. After this date, any website areas still using antiquated Smarty templates will need to be updated to use PHP templates.

If you wish to continue using Smarty templates after this date, the only way to do so is for us to stop pushing software updates to avoid breaking your websites.

This page contains information about moving over from the Smarty template system to PHP-based templates.

Setting up New Templates

Copies of our newest templates can be found here:

https://support.elevatedx.com/newest_templates.php

You can always see the various templates in action on our demo site by requesting a demo u/p here:
https://www.elevatedx.com/demo.php

Either your webmaster can set up new templates via the following guide:

https://support.elevatedx.com/index.php?/Knowledgebase/Article/View/285

Or you can contact support to set up a new area using PHP templates. You can contact our support here:

https://support.elevatedx.com/

Removing Areas No Longer In Use

If your system was using Smarty templates but no longer has active areas using Smarty, these areas must be removed from the system. This can be done by clicking the Gear Icon in the upper right-hand menu and selecting "Manage Site Areas" from the dropdown.

On this page, areas that are using Smarty are shown in red. If the "Last Viewed" section shows that this area has not been viewed in several months, you should be able to safely remove this from your system. Otherwise, only remove an area once you have migrated what is in use to use the updated PHP templates.

Stopping Software Updates

If you plan on continuing to use the Smarty template system after January 31st, 2024, please contact support. We will disable software updates for your site. After February 1st, 2024, in order to turn software updates back on, we will require that Smarty templates are no longer in use on any of your sites.

(0 vote(s))
Helpful
Not helpful

Comments (0)